Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 02, 2023 - 09:00 UTC
Scheduled
We will be conducting a planned maintenance for the distributed storage system, upgrading its components. The process is not expected to incur any downtime for the customer deployments.
Posted Oct 26, 2023 - 17:27 UTC
This scheduled maintenance affected: Deployment Zones (Controller at aws-us-west-2).