Database performance degradation
Incident Report for Tyk Cloud Status
Resolved
The root cause fix has been deployed to all available zones. All systems operating normally.
Posted Jun 08, 2022 - 11:07 UTC
Update
All systems are operating normally. The root cause fix has been implemented and will be deployed shortly.
Posted Jun 07, 2022 - 15:18 UTC
Monitoring
The mitigation is applied to all the affected zones. Our team is continuing to monitor the system while the root cause fix is being implemented.
Posted Jun 07, 2022 - 10:11 UTC
Update
Mitigation is rolled out to the majority of affected zones.
Posted Jun 07, 2022 - 10:01 UTC
Update
The mitigation is being rolled out to all the affected zones.
Posted Jun 07, 2022 - 09:45 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 07, 2022 - 09:30 UTC
Identified
The likely cause is identified. Mitigation is being applied until the root cause fix is implemented and deployed.
Posted Jun 07, 2022 - 09:14 UTC
Update
Alert acknowledged: "Database performance degradation"
Posted Jun 07, 2022 - 09:11 UTC
Investigating
Due to a bug in the recent release we're experiencing degraded database performance, affecting the Control Planes operations in multiple regions as well as ability to manage deployments and accounts in Tyk Cloud. Mitigation is being applied until the fix is implemented.
Posted Jun 07, 2022 - 09:11 UTC
This incident affected: Deployment Zones (Controller at aws-eu-west-2, Controller at aws-eu-central-1, Controller at aws-us-east-1, Controller at aws-us-west-2, Controller at aws-ap-southeast-1) and Web UI (Dashboard, Billing).